Mailer-Project Bug-Tracker - Branch 0.2.1-FINAL
View Issue Details
0000118Branch 0.2.1-FINALCode Standardspublic2009-04-03 09:162016-11-23 10:05
ReporterQuix0r 
Assigned ToQuix0r 
PriorityimmediateSeveritytweakReproducibilityN/A
StatusclosedResolutionfixed 
PlatformPHP5-LatestOSLinuxOS Version2.6
Product Version0.2.1-FINAL 
Target Version0.2.1-FINALFixed in Version0.2.1-FINAL 
Summary0000118: Namenskonvention fuer Funktionen
DescriptionDie im Script verwendeten Funktionen sind derzeit nur schwer von Konstanten unterscheidbar, abgesehen davon, dass diese stark abgebaut werden sollen, und sollten daher umbenannt werden.

Dabei sollte zum Unterschied zu Konstanten die ungarische oder Hoeckerschreibweise verwendet werden:

DIES_IST_EINE_KONSTANTE - Wird nicht direkt eingebunden, sondern per constant('DIES_IST_EINE_KONSTANTE') abgefragt, bzw. mit defined('DIES_IST_EINE_KONSTANTE') ueberprueft.

diesIstEineFunktion() - Die Namen sollten nicht abgekuerzt sein, wie z.B. das bei ADD_DESCR() der Fall ist, zudem sollten sie "redent" sein, also z.B. getArrayFromDirectory() ist ein guter Name, hingehen myMethod() schon weniger.
Additional InformationAnmerkung: Konstanten sind lahm und werden daher auch bei diesem Projekt, bis auf __SECURITY, nicht mehr verwendet.
Tagsconstants, functions, naming convention
Attached Files

Notes
(0000547)
Quix0r   
2012-06-06 12:00   
(Last edited: 2012-06-15 16:20)
Ich denke, das ist soweit alles abgeschlossen, bis auf die Filter-Funktionen. Sollten diese auch umbenannt werden, dann bitte dies mitteilen.

Das Umbenennen von Filtern kann aber sehr komplex werden, da auch die Daten in der Tabelle "mailer_filters" (ist keine neue Tabakmarke! ;-) ) umbenannt werden muessen.

(0000572)
Quix0r   
2012-10-07 20:52   
Ich denke aufgrund der genannten kommenden Problemen lasse ich das Umbenennen von Filtern sein, und ich muss auch sagen, dass sie mir so benannt auch gefallen.

Ich mache hier dann mal zu.
(0000649)
Quix0r   
2016-11-23 10:05   
Und zu damit.

Issue History
2009-04-03 09:16Quix0rNew Issue
2009-04-03 09:20Quix0rProjectionnone => major rework
2009-04-03 09:20Quix0rETAnone => < 1 month
2009-04-06 19:31Quix0rSticky IssueNo => Yes
2009-11-25 21:56Quix0rFixed in Version => 0.2.1-FINAL
2010-03-02 16:33Quix0rFixed in Version0.2.1-FINAL =>
2010-05-28 16:27Quix0rBuildSVN-HEAD => 0.2.1-FINAL
2010-05-28 16:40Quix0rProduct Version => 0.2.1-FINAL
2010-06-08 00:28Quix0rAdditional Information Updatedbug_revision_view_page.php?rev_id=103#r103
2010-06-20 17:03Quix0rAssigned To => Quix0r
2010-06-20 17:03Quix0rStatusnew => assigned
2012-06-06 12:00Quix0rNote Added: 0000547
2012-06-06 12:00Quix0rStatusassigned => feedback
2012-06-15 16:20Quix0rNote Edited: 0000547bug_revision_view_page.php?bugnote_id=547#r164
2012-06-17 21:04Quix0rSeverityfeature => tweak
2012-06-17 21:04Quix0rCategoryFeature Request => Naming Convention
2012-10-07 20:52Quix0rNote Added: 0000572
2012-10-07 20:52Quix0rStatusfeedback => assigned
2012-10-07 20:52Quix0rStatusassigned => resolved
2012-10-07 20:52Quix0rFixed in Version => 0.2.1-FINAL
2012-10-07 20:52Quix0rResolutionopen => fixed
2012-10-07 20:53Quix0rTag Attached: naming convention
2012-10-07 20:53Quix0rTag Attached: constants
2012-10-07 20:53Quix0rTag Attached: functions
2016-11-23 09:13Quix0rCategoryNaming Convention => Code Standards
2016-11-23 10:05Quix0rStatusresolved => closed
2016-11-23 10:05Quix0rNote Added: 0000649