2018-12-18 22:59 UTC


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000118Branch 0.2.1-FINALCode Standardspublic2016-11-23 10:05
ReporterQuix0r 
Assigned ToQuix0r 
PriorityimmediateSeveritytweakReproducibilityN/A
StatusclosedResolutionfixed 
PlatformPHP5-LatestOSLinuxOS Version2.6
Product Version0.2.1-FINAL 
Target Version0.2.1-FINALFixed in Version0.2.1-FINAL 
Summary0000118: Namenskonvention fuer Funktionen
DescriptionDie im Script verwendeten Funktionen sind derzeit nur schwer von Konstanten unterscheidbar, abgesehen davon, dass diese stark abgebaut werden sollen, und sollten daher umbenannt werden.

Dabei sollte zum Unterschied zu Konstanten die ungarische oder Hoeckerschreibweise verwendet werden:

DIES_IST_EINE_KONSTANTE - Wird nicht direkt eingebunden, sondern per constant('DIES_IST_EINE_KONSTANTE') abgefragt, bzw. mit defined('DIES_IST_EINE_KONSTANTE') ueberprueft.

diesIstEineFunktion() - Die Namen sollten nicht abgekuerzt sein, wie z.B. das bei ADD_DESCR() der Fall ist, zudem sollten sie "redent" sein, also z.B. getArrayFromDirectory() ist ein guter Name, hingehen myMethod() schon weniger.
Additional InformationAnmerkung: Konstanten sind lahm und werden daher auch bei diesem Projekt, bis auf __SECURITY, nicht mehr verwendet.
Tagsconstants, functions, naming convention
Attached Files

-Relationships Relation Graph ] Dependency Graph ]
+Relationships

-Notes

~0000547

Quix0r (administrator)

Last edited: 2012-06-15 16:20

View 2 revisions

Ich denke, das ist soweit alles abgeschlossen, bis auf die Filter-Funktionen. Sollten diese auch umbenannt werden, dann bitte dies mitteilen.

Das Umbenennen von Filtern kann aber sehr komplex werden, da auch die Daten in der Tabelle "mailer_filters" (ist keine neue Tabakmarke! ;-) ) umbenannt werden muessen.

~0000572

Quix0r (administrator)

Ich denke aufgrund der genannten kommenden Problemen lasse ich das Umbenennen von Filtern sein, und ich muss auch sagen, dass sie mir so benannt auch gefallen.

Ich mache hier dann mal zu.

~0000649

Quix0r (administrator)

Und zu damit.
+Notes

-Issue History
Date Modified Username Field Change
2009-04-03 09:16 Quix0r New Issue
2009-04-03 09:20 Quix0r Projection none => major rework
2009-04-03 09:20 Quix0r ETA none => < 1 month
2009-04-06 19:31 Quix0r Sticky Issue No => Yes
2009-11-25 21:56 Quix0r Fixed in Version => 0.2.1-FINAL
2010-03-02 16:33 Quix0r Fixed in Version 0.2.1-FINAL =>
2010-05-28 16:27 Quix0r Build SVN-HEAD => 0.2.1-FINAL
2010-05-28 16:40 Quix0r Product Version => 0.2.1-FINAL
2010-06-08 00:28 Quix0r Additional Information Updated View Revisions
2010-06-20 17:03 Quix0r Assigned To => Quix0r
2010-06-20 17:03 Quix0r Status new => assigned
2012-06-06 12:00 Quix0r Note Added: 0000547
2012-06-06 12:00 Quix0r Status assigned => feedback
2012-06-15 16:20 Quix0r Note Edited: 0000547 View Revisions
2012-06-17 21:04 Quix0r Severity feature => tweak
2012-06-17 21:04 Quix0r Category Feature Request => Naming Convention
2012-10-07 20:52 Quix0r Note Added: 0000572
2012-10-07 20:52 Quix0r Status feedback => assigned
2012-10-07 20:52 Quix0r Status assigned => resolved
2012-10-07 20:52 Quix0r Fixed in Version => 0.2.1-FINAL
2012-10-07 20:52 Quix0r Resolution open => fixed
2012-10-07 20:53 Quix0r Tag Attached: naming convention
2012-10-07 20:53 Quix0r Tag Attached: constants
2012-10-07 20:53 Quix0r Tag Attached: functions
2016-11-23 09:13 Quix0r Category Naming Convention => Code Standards
2016-11-23 10:05 Quix0r Status resolved => closed
2016-11-23 10:05 Quix0r Note Added: 0000649
+Issue History